Welcome, Guest. Please login or register.
Did you miss your activation email?
Monday 10 December 2018, 05:06:52 pm

Login with username, password and session length

Visit the official Endian Community Mailinglist  HERE
13847 Posts in 4212 Topics by 5877 Members
Latest Member: CharlesMet
Search:     Advanced search
+  EFW Support
|-+  Development
| |-+  EFW Wishlist
| | |-+  Authentication feature for mail smart host
0 Members and 0 Guests are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Authentication feature for mail smart host  (Read 13871 times)
vlongjvc
Full Member
***
Offline Offline

Posts: 27


« on: Monday 05 April 2010, 01:29:07 pm »

I wish for authentication feature in event notifications using mail smart host, because our Mailserver requires authentification when mail sender attempt to send email via smart host.
Logged
gyp_the_cat
Full Member
***
Offline Offline

Posts: 81



WWW
« Reply #1 on: Wednesday 07 April 2010, 01:42:37 am »

Hi vlongjvc,

What version of Endian are you on?

In Proxy - SMTP - Advanced, there is an option for smart host with authentication, and the relay messages should be logged in the main /var/log/mail.log.

Gyp
Logged
vlongjvc
Full Member
***
Offline Offline

Posts: 27


« Reply #2 on: Wednesday 07 April 2010, 12:28:13 pm »

Hi gyp_the_cat,

I am using EFW 2.3.0, do you mean if I want to use "Event notifications" function I need to turn on SMTP proxy?

Thanks for your reply,
Logged
gyp_the_cat
Full Member
***
Offline Offline

Posts: 81



WWW
« Reply #3 on: Wednesday 07 April 2010, 06:03:33 pm »

Are all your clients behind Endian using the your ISPs Smart Host directly I take it?

Sorry I think I mis-understood your original query Sad
Logged
vlongjvc
Full Member
***
Offline Offline

Posts: 27


« Reply #4 on: Wednesday 07 April 2010, 06:26:44 pm »

Hi gyp_the_cat,

So sorry to make you confused with my question, I mean "Event notifications" in "Sytem" menu. I think this function will send an alert email to system admin when there is an attack to network. But how to send this alert email when smart host requires authentication?

Thanks for your attention,

Long
Logged
gyp_the_cat
Full Member
***
Offline Offline

Posts: 81



WWW
« Reply #5 on: Wednesday 07 April 2010, 07:00:35 pm »

Hi vlongjvc,

Thats much clearer thank you Smiley

You're right it would be very much a nice to have on a new version, after all sometimes you don't want your email going through a network thats under attack.

The way I see it though there are a  of work arounds:

1) Set the Smart Host for the server thats responsible for delivery of the email, so if I used: mail sender address as endian@mycompany.com, mail recipient address as me@hotmail.com, and mail smart host as mx1.hotmail.com, that should work.

2) Use the SMTP proxy, so as above but in the mail smart host use localhost and make sure that the SMTP proxy is setup to relay from 127.0.0.1 which it should be by default.

Either way, it should do what you want it to do before the guys at Endian fix it Smiley

Gyp
Logged
Steve
Sr. Member
****
Offline Offline

Posts: 108



WWW
« Reply #6 on: Wednesday 07 April 2010, 07:02:51 pm »

I see the problem.
There is a smarthost authentication setting (Proxy > SMTP > Advanced) but it seems to be only relevant if you are using the SMTP Proxy.

The Event Notifications section (System > Event notifications > Settings) has a Mail Smarthost setting but it has no authentication option.
I triggered an event (SSH login attempt) and the email was sent but but was rejected by my smarthost (lack of authentication).

I did however, manage to send an email notification out through my ISP using my ISP allocated email address - this is because I don't need authentication since
a: I am connected to my ISP (via my WAN connection)
b: I used my ISP allocated email address

I can see there is a definite need to have an authentication option.

It's worth reporting this to Endian as a bug (though technically isn't)
Logged

                          
vlongjvc
Full Member
***
Offline Offline

Posts: 27


« Reply #7 on: Monday 12 April 2010, 01:47:46 pm »

Thank you Steve & gyp_the_cat for your feedback, maybe in EFW 2.3.1 it will be fixed. I am waiting for new version of EFW. Thanks all.
Logged
robles
Jr. Member
*
Offline Offline

Posts: 1


« Reply #8 on: Wednesday 16 February 2011, 03:30:51 pm »

Hi there, do you know if there's an update on this? I'm having this same issue, plus a new one:
We use Google apps in our company and GMail requires TLS which -unless I'm mistaken- the Endian's sendmail doesn't support yet.
TLS is used to encrypt the mail as it travels from server to server. As I'm emailing backups, it definitely would be a reallly super nice-to-have.

Thanks!
Robles
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  

Page created in 0.078 seconds with 18 queries.
Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Design by 7dana.com