Welcome, Guest. Please login or register.
Did you miss your activation email?
Wednesday 11 December 2019, 12:21:28 am

Login with username, password and session length

The Latest Endian Firewall is now available for download HERE
13964 Posts in 4252 Topics by 6023 Members
Latest Member: krunal
Search:     Advanced search
+  EFW Support
|-+  Support
| |-+  VPN Support
| | |-+  Help getting OpenVPN working | EFW 3 beta2
0 Members and 0 Guests are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Help getting OpenVPN working | EFW 3 beta2  (Read 6124 times)
0xDECAFBAD
Jr. Member
*
Offline Offline

Posts: 5


« on: Tuesday 17 December 2013, 07:34:45 am »

I can't figure out what I'm doing wrong.  I can't get OpenVPN to work with Windows 7.  I think my biggest issue right now is the certificates.  I'm trying to use PSK authentication but the sake of simplicity but the OpenVPN client for Windows still seems to want a ca key.  When I click "Download PEM File" under ca certificate in the OpenVPN settings section of EFW and put it in my C:\Program Files (x86)\OpenVPN\config folder and change my config file certificate line to read:
pkcs12 cacert.pem

and try to connect it gives me:

Mon Dec 16 14:29:36 2013 Error reading PKCS#12 file cacert.pem: error:0D0680A8:asn1 encoding

The default certificate EFW has in place for OpenVPN is invalid anyways because I revoked it, and when I select use existing certificate none of the certificates I generated in the certificate management show up in the drop down list, and when I select generate new certificate and fill in the information and click Save it looks like nothing happens, and when I refresh the page it reverts to "Use existing certificate" and it has the generic 127.0.0.1 certificate that I had revoked.  So I think the issue of certificates not working at all is going to be the first thing I have to get solved.  Is anyone having this issue or is it just me?
Logged
hinge
Full Member
***
Offline Offline

Posts: 93


« Reply #1 on: Friday 20 December 2013, 01:32:06 pm »

Im also have a same problem via IPSEC connection. Huh Huh Huh
Logged
mmiat
Sr. Member
****
Offline Offline

Gender: Male
Posts: 236


WWW
« Reply #2 on: Monday 06 January 2014, 09:58:22 pm »

I've 3.0 b2 now, but when I tried I used ca, not pkcs12

Code:
ca "C:\\vpn\\test\\certificato.pem"
Logged

---------------------
IT Consultant
www.fsw.it
Hardware & Software
Pages: [1] Go Up Print 
« previous next »
Jump to:  

Page created in 0.047 seconds with 18 queries.
Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Design by 7dana.com