Welcome, Guest. Please login or register.
Did you miss your activation email?
Friday 23 August 2019, 02:40:44 am

Login with username, password and session length

CLICK HERE for the The official Endian Roadmap and Issue tracker
13939 Posts in 4244 Topics by 5974 Members
Latest Member: maironmendes
Search:     Advanced search
+  EFW Support
|-+  Support
| |-+  EFW SMTP, HTTP, SIP, FTP Proxy Support
| | |-+  EFW 3.0 - web filter update is working or not?
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: 1 2 [3] Go Down Print
Author Topic: EFW 3.0 - web filter update is working or not?  (Read 52426 times)
mhLearn
Full Member
***
Offline Offline

Posts: 10


« Reply #30 on: Thursday 06 March 2014, 01:49:46 pm »

Look at this thread with an error I got see if it helps you.
h.t.t.p://www-efwsupport.com/index.php/topic,3942.msg10638.html#msg10638


hi,

after many tries, finally able to upgraded the squid, then updated the web filter, and web proxy service was running. Access internet was ok thereafter, but access policy and allowed tcp port control was't working.

but then after restarted the efw, everything is not working anymore. Web proxy service is not running anymore.  Headache
Logged
thaobn20
Full Member
***
Offline Offline

Posts: 14


« Reply #31 on: Thursday 06 March 2014, 02:25:40 pm »

Update Squid success working good

Step 1:

Code:
rm -rf /usr/share/squid/errors/sr*

Step 2:
Code:
efw-upgrade -s
select 2
enter you username Register Endian.com ==> enter

Update success EFW working good!
Logged
dda
Sr. Member
****
Offline Offline

Posts: 227


« Reply #32 on: Friday 07 March 2014, 02:55:52 am »

I have been having a similar problem and I have to go and reapply the access policies under proxy and it immediately starts to work.  Do you have any denials in your access policies?
Logged
mhLearn
Full Member
***
Offline Offline

Posts: 10


« Reply #33 on: Tuesday 18 March 2014, 08:48:16 pm »

after deleted all the web filter rules and access policy and re-created, things were working fine, Web Proxy service was running (under Status), but after it was restarted, then web proxy service was not running anymore, and had to turned off the http proxy in order to get internet access. Anymore suggestion to get the web proxy running?
Logged
dda
Sr. Member
****
Offline Offline

Posts: 227


« Reply #34 on: Wednesday 19 March 2014, 12:46:42 am »

Mine is working fine after an update a few weeks back,did you download the last update on the development channel?
Logged
mhLearn
Full Member
***
Offline Offline

Posts: 10


« Reply #35 on: Friday 21 March 2014, 12:33:42 pm »

yes did that, but still helpless. Maybe have to do fresh installation to try if the problem still persist.
Logged
dda
Sr. Member
****
Offline Offline

Posts: 227


« Reply #36 on: Saturday 22 March 2014, 01:36:26 am »

What kind of authentication are you running?
Logged
mhLearn
Full Member
***
Offline Offline

Posts: 10


« Reply #37 on: Tuesday 25 March 2014, 06:32:15 pm »

authentication was disabled under access policy.
Logged
dda
Sr. Member
****
Offline Offline

Posts: 227


« Reply #38 on: Wednesday 26 March 2014, 01:09:28 am »

Is it transparent or non transparent.  I think it should be transparent.
Logged
mhLearn
Full Member
***
Offline Offline

Posts: 10


« Reply #39 on: Thursday 27 March 2014, 01:31:53 pm »

transparent. according to feedback in Jira endian, they are in the progress to fix this issue
Logged
bnhansen
Jr. Member
*
Offline Offline

Posts: 3


« Reply #40 on: Thursday 08 May 2014, 11:40:09 am »

Does anyone know if this problem has been resolved - i.e. squid not running properly (error message is No valid signing SSL certificate configured for http_port 0.0.0.0:8080).  Although Web Proxy says on Status it's running, if the zone is set to transparent no clients can browse the internet.

Trying to restart squid gives the following log:

/etc/init.d/squid restart
Stopping squid:                                            [FAILED]
Starting squid:                                            [FAILED]
2014/05/07 21:36:36| Startup: Initializing Authentication Schemes ...
2014/05/07 21:36:36| Startup: Initialized Authentication Scheme 'basic'
2014/05/07 21:36:36| Startup: Initialized Authentication Scheme 'digest'
2014/05/07 21:36:36| Startup: Initialized Authentication Scheme 'negotiate'
2014/05/07 21:36:36| Startup: Initialized Authentication Scheme 'ntlm'
2014/05/07 21:36:36| Startup: Initialized Authentication.
2014/05/07 21:36:36| Processing Configuration File: /etc/squid/squid.conf (depth 0)
2014/05/07 21:36:36| Processing: shutdown_lifetime 1 seconds
2014/05/07 21:36:36| Processing: icp_port 0
2014/05/07 21:36:36| Processing: workers 1
2014/05/07 21:36:36| Processing: http_port 0.0.0.0:8080 ssl-bump cert=/var/efw/proxy/https_cert generate-host-certificates=on
2014/05/07 21:36:36| Processing: http_port 0.0.0.0:18080 intercept ssl-bump cert=/var/efw/proxy/https_cert generate-host-certificates=on
2014/05/07 21:36:36| Starting Authentication on port 0.0.0.0:18080
2014/05/07 21:36:36| Disabling Authentication on port 0.0.0.0:18080 (interception enabled)
2014/05/07 21:36:36| Disabling IPv6 on port 0.0.0.0:18080 (interception enabled)
2014/05/07 21:36:36| Processing: https_port 0.0.0.0:18081 intercept ssl-bump cert=/var/efw/proxy/https_cert generate-host-certificates=on
2014/05/07 21:36:36| Starting Authentication on port 0.0.0.0:18081
2014/05/07 21:36:36| Disabling Authentication on port 0.0.0.0:18081 (interception enabled)
2014/05/07 21:36:36| Disabling IPv6 on port 0.0.0.0:18081 (interception enabled)
2014/05/07 21:36:36| Processing: ssl_bump none localhost
2014/05/07 21:36:36| Processing: acl bypass_windows dstdomain "/etc/squid/acls/https_bypass_rules.acl"
2014/05/07 21:36:36| Processing: ssl_bump none bypass_windows
2014/05/07 21:36:36| Processing: ssl_bump server-first all
2014/05/07 21:36:36| Processing: acl https_proto proto https
2014/05/07 21:36:36| Processing: always_direct allow https_proto
2014/05/07 21:36:36| Processing: sslproxy_cert_error allow all
2014/05/07 21:36:36| Processing: sslproxy_flags DONT_VERIFY_PEER
2014/05/07 21:36:36| Processing: acl no_cache_domains dstdomain "/etc/squid/acls/dst_nocache.acl"
2014/05/07 21:36:36| Processing: cache deny no_cache_domains
2014/05/07 21:36:36| Processing: cache_effective_user squid
2014/05/07 21:36:36| Processing: cache_effective_group squid
2014/05/07 21:36:36| Processing: pid_filename /var/run/squid.pid
2014/05/07 21:36:36| Processing: cache_mem 40 MB
2014/05/07 21:36:36| Processing: cache_dir rock /var/spool/squid 500 max-size=32768
2014/05/07 21:36:36| Processing: error_directory /usr/share/squid/errors/en
2014/05/07 21:36:36| Processing: icon_directory /usr/share/squid/icons
2014/05/07 21:36:36| Processing: max_filedesc 90793
2014/05/07 21:36:36| Processing: server_persistent_connections off
2014/05/07 21:36:36| Processing: half_closed_clients off
2014/05/07 21:36:36| Processing: buffered_logs on
2014/05/07 21:36:36| Processing: cache_log /dev/null
2014/05/07 21:36:36| Processing: cache_access_log /dev/null
2014/05/07 21:36:36| Processing: cache_store_log none
2014/05/07 21:36:36| Processing: log_mime_hdrs off
2014/05/07 21:36:36| Processing: forwarded_for delete
2014/05/07 21:36:36| Processing: auth_param basic program /usr/lib/squid/basic_ncsa_auth /var/efw/proxy/ncsausers
2014/05/07 21:36:36| Processing: auth_param basic children 20
2014/05/07 21:36:36| Processing: auth_param basic realm Proxy Server
2014/05/07 21:36:36| Processing: auth_param basic credentialsttl 60 minutes
2014/05/07 21:36:36| Processing: acl for_auth_users proxy_auth REQUIRED
2014/05/07 21:36:36| Processing: acl from_all                src all
2014/05/07 21:36:36| Processing: acl to_all                  dst all
2014/05/07 21:36:36| Processing: acl from_localhost          src 127.0.0.1/32
2014/05/07 21:36:36| Processing: acl CONNECT                 method CONNECT
2014/05/07 21:36:36| Processing: acl to_http_port            port 80
2014/05/07 21:36:36| Processing: acl to_https_port           port 10443
2014/05/07 21:36:36| Processing: acl to_proxy_port           port 8080
2014/05/07 21:36:36| Processing: acl to_blue_interface    dst 10.0.0.1
2014/05/07 21:36:36| Processing: acl to_orange_interface    dst 192.168.10.1
2014/05/07 21:36:36| Processing: acl to_green_interface    dst 192.168.1.28
2014/05/07 21:36:36| Processing: acl from_blue          src "/etc/squid/acls/blue_subnets.acl"
2014/05/07 21:36:36| Processing: acl to_blue            dst "/etc/squid/acls/blue_subnets.acl"
2014/05/07 21:36:36| Processing: acl from_orange          src "/etc/squid/acls/orange_subnets.acl"
2014/05/07 21:36:36| Processing: acl to_orange            dst "/etc/squid/acls/orange_subnets.acl"
2014/05/07 21:36:36| Processing: acl from_green          src "/etc/squid/acls/green_subnets.acl"
2014/05/07 21:36:36| Processing: acl to_green            dst "/etc/squid/acls/green_subnets.acl"
2014/05/07 21:36:36| Processing: acl allowed_ports       port "/etc/squid/acls/ports.acl"
2014/05/07 21:36:36| Processing: acl allowed_sslports    port "/etc/squid/acls/sslports.acl"
2014/05/07 21:36:36| Processing: acl within_timeframe_rule0 time MTWHFAS 00:00-24:00
2014/05/07 21:36:36| Processing: refresh_pattern -i (/cgi-bin/|\?) 0 0% 0
2014/05/07 21:36:36| Processing: refresh_pattern .            0 20% 4320
2014/05/07 21:36:36| Processing: cache deny      from_localhost
2014/05/07 21:36:36| Processing: cache deny      CONNECT
2014/05/07 21:36:36| Processing: cache allow     from_all
2014/05/07 21:36:36| Processing: acl cachemanageracl proto cache_object
2014/05/07 21:36:36| Processing: http_access allow cachemanageracl from_localhost
2014/05/07 21:36:36| Processing: http_access deny cachemanageracl
2014/05/07 21:36:36| Processing: snmp_port 3401
2014/05/07 21:36:36| Processing: acl snmppublic snmp_community public
2014/05/07 21:36:36| Processing: snmp_access allow snmppublic from_localhost
2014/05/07 21:36:36| Processing: snmp_access deny from_all
2014/05/07 21:36:36| Processing: http_access allow   from_localhost
2014/05/07 21:36:36| Processing: http_access allow   from_green to_green_interface to_http_port
2014/05/07 21:36:36| Processing: http_access allow   from_green to_green_interface to_https_port
2014/05/07 21:36:36| Processing: http_access allow   CONNECT from_green to_green_interface to_https_port
2014/05/07 21:36:36| Processing: http_access deny    to_blue_interface to_https_port
2014/05/07 21:36:36| Processing: http_access deny    to_blue_interface to_proxy_port
2014/05/07 21:36:36| Processing: http_access deny    to_orange_interface to_https_port
2014/05/07 21:36:36| Processing: http_access deny    to_orange_interface to_proxy_port
2014/05/07 21:36:36| Processing: http_access deny    to_green_interface to_https_port
2014/05/07 21:36:36| Processing: http_access deny    to_green_interface to_proxy_port
2014/05/07 21:36:36| Processing: http_access deny    !allowed_ports !allowed_sslports
2014/05/07 21:36:36| Processing: http_access deny    CONNECT !allowed_sslports
2014/05/07 21:36:36| Processing: http_access allow   within_timeframe_rule0
2014/05/07 21:36:36| Processing: http_access deny    from_all
2014/05/07 21:36:36| Processing: http_reply_access allow from_localhost
2014/05/07 21:36:36| Processing: http_reply_access allow   within_timeframe_rule0
2014/05/07 21:36:36| Processing: http_reply_access deny from_all
2014/05/07 21:36:36| Processing: maximum_object_size 1024 KB
2014/05/07 21:36:36| Processing: minimum_object_size 0 KB
2014/05/07 21:36:36| Processing: cache_mgr brenda.neilsonhansen@foxdenfarm-usa.com
2014/05/07 21:36:36| Processing: visible_hostname off
2014/05/07 21:36:36| Processing: icap_enable on
2014/05/07 21:36:36| Processing: icap_service_revival_delay 30
2014/05/07 21:36:36| Processing: icap_service_failure_limit -1
2014/05/07 21:36:36| Processing: icap_preview_enable on
2014/05/07 21:36:36| Processing: icap_preview_size    128
2014/05/07 21:36:36| Processing: icap_send_client_ip  on
2014/05/07 21:36:36| Processing: icap_send_client_username  on
2014/05/07 21:36:36| Processing: include /etc/squid/squid.conf.d/*.conf
2014/05/07 21:36:36| Processing Configuration File: /etc/squid/squid.conf.d/clamav.conf (depth 1)
2014/05/07 21:36:36| Processing: icap_service service_av_req reqmod_precache icap://127.0.0.1:1344/clamd_scan bypass=off
2014/05/07 21:36:36| Processing: icap_service service_av respmod_precache icap://127.0.0.1:1344/clamd_scan bypass=on
2014/05/07 21:36:36| Processing Configuration File: /etc/squid/squid.conf.d/empty.conf (depth 1)
2014/05/07 21:36:36| Processing Configuration File: /etc/squid/squid.conf.d/urlfilter.conf (depth 1)
2014/05/07 21:36:36| Processing: adaptation_access service_av deny cachemanageracl
2014/05/07 21:36:36| Processing: adaptation_access service_av_req deny cachemanageracl
2014/05/07 21:36:36| Processing: adaptation_access service_av allow   within_timeframe_rule0
2014/05/07 21:36:36| Processing: adaptation_access service_av_req allow   within_timeframe_rule0
2014/05/07 21:36:36| Processing: adaptation_access service_av deny all
2014/05/07 21:36:36| Processing: adaptation_access service_av_req deny all
2014/05/07 21:36:36| WARNING: max_filedescriptors disabled. Operating System setrlimit(RLIMIT_NOFILE) is missing.
2014/05/07 21:36:36| Initializing https proxy context
2014/05/07 21:36:36| Initializing http_port 0.0.0.0:8080 SSL context
2014/05/07 21:36:36| Using certificate in /var/efw/proxy/https_cert
FATAL: No valid signing SSL certificate configured for http_port 0.0.0.0:8080
Squid Cache (Version 3.3.Cool: Terminated abnormally.
CPU Usage: 0.034 seconds = 0.023 user + 0.011 sys
Maximum Resident Size: 24080 KB
Page faults with physical i/o: 0
root@efw-1399453170:~ #
Logged
TheEricHarris
Full Member
***
Offline Offline

Posts: 86


« Reply #41 on: Thursday 22 May 2014, 01:34:23 am »

Ugh, is content filter not working?  I'm trying to get my custom profiles setup.  I block everything with "**" in the Deny list and then add the websites in the Allowed list that I only want them to access.  Doesn't work.

The help menu doesn't work, 404 error. 


Get a ton of these in /var/log/messages:
May 21 09:31:59 gw1 httpd: [Wed May 21 09:31:58 2014] [error] [client 172.30.100.40] File does not exist: /home/httpd/html/images/bubble_green_sign.png
May 21 09:30:43 gw1 httpd: [Wed May 21 09:30:42 2014] [error] [client 172.30.100.40] File does not exist: /home/httpd/html/include/updates.css

Why so many bugs?
Logged
nickchacha
Jr. Member
*
Offline Offline

Posts: 2


« Reply #42 on: Saturday 06 December 2014, 11:22:25 pm »

Did anyone got this Unknown Last Update fix.
Am stuck on it and would appropriate if someone can assist with the best solution
Logged
Pages: 1 2 [3] Go Up Print 
« previous next »
Jump to:  

Page created in 0.103 seconds with 18 queries.
Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Design by 7dana.com