Welcome, Guest. Please login or register.
Did you miss your activation email?
Monday 19 April 2021, 07:18:11 pm

Login with username, password and session length

Visit the official Endian Community Mailinglist  HERE
14085 Posts in 4293 Topics by 6184 Members
Latest Member: nivaldo
Search:     Advanced search
+  EFW Support
|-+  Support
| |-+  EFW SMTP, HTTP, SIP, FTP Proxy Support
| | |-+  HTTP proxy with Authentication
0 Members and 0 Guests are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: HTTP proxy with Authentication  (Read 9902 times)
uniquegodwin
Jr. Member
*
Offline Offline

Posts: 6


« on: Friday 31 October 2008, 02:41:28 pm »

Hello everyone,
I've setup the HTTP proxy with authentication...
Tried the transparent mode too...

But,when a user tries to browse the internet,he is not prompted for username and password...

Please help me out....why is this happening...?

Thanks
Logged
blobbi
Full Member
***
Offline Offline

Gender: Male
Posts: 88


« Reply #1 on: Friday 31 October 2008, 05:05:28 pm »

you must change from Transparent to Authentification on Transparent all traffic is going into Proxy with no Auth.
Logged

german speaking Endian Community Forum at https://www.efw-forum.de
uniquegodwin
Jr. Member
*
Offline Offline

Posts: 6


« Reply #2 on: Friday 31 October 2008, 05:58:35 pm »


Hello Blobbi,
Thanks for the reply...
But,if I set the proxy to authentication,the user isn't redirected to any page asking for username/password.
The browser says "Waiting for reply..." when I open google.com on my laptop.

Thanks...
Logged
uniquegodwin
Jr. Member
*
Offline Offline

Posts: 6


« Reply #3 on: Friday 31 October 2008, 06:25:41 pm »

The trial version of Kerio winroute had a way where you could redirect all requests to a login page.
Internet would work only after they login.
How can I do something similar using Endian?
Logged
blobbi
Full Member
***
Offline Offline

Gender: Male
Posts: 88


« Reply #4 on: Friday 31 October 2008, 06:33:42 pm »

think is a little Problem with your configuration.
wich version rc2 or rc3?

User Auth is local or LDAP or what
Logged

german speaking Endian Community Forum at https://www.efw-forum.de
uniquegodwin
Jr. Member
*
Offline Offline

Posts: 6


« Reply #5 on: Friday 31 October 2008, 06:46:05 pm »

I think its RC2.I just downloaded this ISO yesterday......

The proxy authentication works if I set the proxy server setting on the browser.
I'm using Windows authentication.

But,otherwise,it doesn't redirect users to a login page...
Thanks
Logged
blobbi
Full Member
***
Offline Offline

Gender: Male
Posts: 88


« Reply #6 on: Friday 31 October 2008, 07:31:35 pm »

there is no logipage only the Auth Screen from Browser the same Window when you login to the efw gui is open
Logged

german speaking Endian Community Forum at https://www.efw-forum.de
uniquegodwin
Jr. Member
*
Offline Offline

Posts: 6


« Reply #7 on: Friday 31 October 2008, 07:44:50 pm »

No,I didnt mean that...
I found the right way to express what I need I think.
I am basically trying to get something like the HOTSPOT functionality....where every user is required to login to use the internet through the transparent proxy Smiley
This is exactly what I wish I could do.
I found in one of the posts that its not available in the community edition.

But then....Is there any alternative way?Please?
Thanks
Logged
blobbi
Full Member
***
Offline Offline

Gender: Male
Posts: 88


« Reply #8 on: Friday 31 October 2008, 08:17:58 pm »

yes hotspot function is not aviable in community edition,
may try to do a selfmade coding, but thinks is not easy
Logged

german speaking Endian Community Forum at https://www.efw-forum.de
merlin_52
Jr. Member
*
Offline Offline

Posts: 2


« Reply #9 on: Sunday 11 January 2009, 02:36:09 am »

Hello to you all!

I have the same problem with the Proxy Authentification.

I create a Username "Internet" and a password "xxxxxx". The adress of my Endian wrote I into the Firefox with Port 8080.

When I open the Firefox, he ask me after a Username and a Passwort, which I save it before in the Endian.

But the Authentification appears once again.

What is my problem?  Wink

A "ping" to the internet is ok, i get an answer.


Best regards

Merlin
Logged
merlin_52
Jr. Member
*
Offline Offline

Posts: 2


« Reply #10 on: Thursday 19 March 2009, 07:04:32 am »

Hello!

I have the answer to the problem  Wink

You must write the user in small letters  Cool

Best regards

The happy Merlin
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  

Page created in 0.094 seconds with 20 queries.
Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Design by 7dana.com