Welcome, Guest. Please login or register.
Did you miss your activation email?
Monday 25 January 2021, 08:23:09 am

Login with username, password and session length

CLICK HERE for the The official Endian Roadmap and Issue tracker
14072 Posts in 4287 Topics by 6157 Members
Latest Member: myeniad@ybu.edu.tr
Search:     Advanced search
+  EFW Support
|-+  Support
| |-+  General Support
| | |-+  Upgrade from 2.2 to 2.3 Failed with efw-upgrade command
0 Members and 0 Guests are viewing this topic. « previous next »
Pages: [1] 2 Go Down Print
Author Topic: Upgrade from 2.2 to 2.3 Failed with efw-upgrade command  (Read 45409 times)
cmateski
Full Member
***
Offline Offline

Posts: 19


« on: Wednesday 28 October 2009, 02:11:48 pm »

I have the base installation of endian version 2.2rc4. 
I did a full backup before starting the upgrade. 
I registered my account on the endian site.

I followed the instructions in the email:
Welcome to the Endian Community

Your email is validated and your account is active

Now follow these 5 steps to keep your Endian Firewall Community up to date:

   1. Enable SSH access on your firewall
   2. Open your favorite SSH terminal and connect to the firewall (On Windows you may use putty)
   3. If your Endian Firewall Community is older than version 2.2 please run

      root@efw-2:~ # rpm -ivh http://updates.endian.org/upgrade.rpm
   4. Run the efw-upgrade script

      root@efw-2:~ # efw-upgrade
      Please choose the appropriate channel for your environment and hit [ENTER]:
      1) Production (stable releases)
      2) Development (bleeding edge)
      1
      Please enter your username and hit [ENTER]:


Output from command to upgrade to version 2.2:
root@efw:~ # rpm -ivh http://updates.endian.org/upgrade.rpm
Retrieving http://updates.endian.org/upgrade.rpm
Preparing...                ########################################### [100%]
        package efw-upgrade-2.2.1-0.endian0 is already installed



Output from teh efw-upgrade command:
root@efw:/usr/local/bin # efw-upgrade
Loading cache...
Up cache...                         ######################################################## [100%]

Fetching information for 'efw-community'...
-> http://cmateski@yahoo.com:*@updates.endian.org/stable/repodata/repomd.xml
repomd.xml                                ######################################################## [ 33%]

Up cache...                         ######################################################## [100%]

Channels have no new packages.
Loading cache...
Up cache...                         ######################################################## [100%]

Computing transaction...
No interesting upgrades available.


When I previously installed efw I did a fresh installation from CDROM with version 2.2rc4. 
Logged
maximus007
Jr. Member
*
Offline Offline

Posts: 7


« Reply #1 on: Wednesday 28 October 2009, 04:18:23 pm »

I had the same error...
Logged
jonasmartin
Jr. Member
*
Offline Offline

Posts: 1


« Reply #2 on: Wednesday 28 October 2009, 06:12:53 pm »

same error too
Logged
Indianwf
Jr. Member
*
Offline Offline

Posts: 1


« Reply #3 on: Wednesday 28 October 2009, 07:46:26 pm »

same error too !!
Logged
dr.fix
Jr. Member
*
Offline Offline

Posts: 8


« Reply #4 on: Wednesday 28 October 2009, 09:30:51 pm »

The same here, no upgrade found
Logged
dtruffo
Full Member
***
Offline Offline

Posts: 11


« Reply #5 on: Wednesday 28 October 2009, 09:34:47 pm »

No way also here.... I hope we do not need to reinstall from scratch !!
Logged
dr.fix
Jr. Member
*
Offline Offline

Posts: 8


« Reply #6 on: Wednesday 28 October 2009, 09:37:36 pm »

No way also here.... I hope we do not need to reinstall from scratch !!


Probably we'll need to...
but nobody answers, no documentation about upgrade, what efw-upgrade does? nothing... I've never seen a single upgrade from there..
Logged
dtruffo
Full Member
***
Offline Offline

Posts: 11


« Reply #7 on: Wednesday 28 October 2009, 09:42:23 pm »

if reinstallation permits restore of a backup should not be a problem... different if we need to recreate all rules, VPNs, routing tables and so on !!

Let wait if somebody find a way..
I'll try to install from scratch on an offline pc and restore 2.2 configuration !!
Logged
icebrian
Jr. Member
*
Offline Offline

Posts: 8


« Reply #8 on: Wednesday 28 October 2009, 09:44:43 pm »

Had same problema, searched german forums and found:

http://translate.google.com/translate?prev=hp&hl=en&js=y&u=http%3A%2F%2Fwww.efw-forum.de&sl=de&tl=en&history_state0=

Aparently there is no update to v2.3, also not know when or if one will be available.
Logged
rhaarhoff
Jr. Member
*
Offline Offline

Posts: 4


« Reply #9 on: Wednesday 28 October 2009, 09:50:36 pm »

Same issue, looks like the only way to do the upgrade is to:

   1.  Backup the existing configuration data using the backup tool
   2. Install the new release over the existing installation (this will completely wipe the previous installation)
   3. Restore the configuration from backup

Chers,
Logged
cmateski
Full Member
***
Offline Offline

Posts: 19


« Reply #10 on: Thursday 29 October 2009, 01:06:23 am »

No way also here.... I hope we do not need to reinstall from scratch !!


Probably we'll need to...
but nobody answers, no doentation about upgrade, what efw-upgrade does? nothing... I've never seen a single upgrade from there..


The efw-upgrade script is located in /usr/local/bin.  I did a 'more' on the file to see which commands it actually uses.  I didnt get very far as it was late. 
Logged
bl117
Full Member
***
Offline Offline

Posts: 20


« Reply #11 on: Thursday 29 October 2009, 06:45:14 am »

Any news on if backups can be restored?  i'm a little disapointed that the upgrade script was useless.
Logged
cmateski
Full Member
***
Offline Offline

Posts: 19


« Reply #12 on: Thursday 29 October 2009, 07:25:25 am »

Any news on if backups can be restored?  i'm a little disapointed that the upgrade script was useless.


Excellent question.  I would love to hear the answer too.  The instructions have you do a backup before executing efw-upgrade.  I would hope that v2.3 could use that backup if needed.  I'm holding out a few more days to see if they sort this upgrade issue out. 
Logged
nopyobe
Full Member
***
Offline Offline

Posts: 13


« Reply #13 on: Thursday 29 October 2009, 09:37:11 am »

I tried to restore a 2.2 backup (Configuration data only) to a 2.3 brand spankin' new install and it broke the web interface.  From the server console, it looked like it worked, but when I went to the firewall through the web interface, I received a "500 Internal Server Error":

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Doesnt look like we have a way to upgrade yet.
Logged
cmateski
Full Member
***
Offline Offline

Posts: 19


« Reply #14 on: Thursday 29 October 2009, 12:23:23 pm »

I tried to restore a 2.2 backup (Configuration data only) to a 2.3 brand spankin' new install and it broke the web interface.  From the server console, it looked like it worked, but when I went to the firewall through the web interface, I received a "500 Internal Server Error":

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Doesnt look like we have a way to upgrade yet.


Ouch!  What a waste of time.  I cant say I blame you for trying though.  It might be worth your time to  it away again versus trying to straighten it out.  You never know if you will get it all.  Good luck!
Logged
Pages: [1] 2 Go Up Print 
« previous next »
Jump to:  

Page created in 0.14 seconds with 18 queries.
Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Design by 7dana.com