Welcome, Guest. Please login or register.
Did you miss your activation email?
Friday 01 March 2024, 01:16:29 am

Login with username, password and session length

Visit the Official Endian Bug tracker  HERE
14245 Posts in 4376 Topics by 6489 Members
Latest Member: GB-gattoboy
Search:     Advanced search
+  EFW Support
|-+  Support
| |-+  EFW SMTP, HTTP, SIP, FTP Proxy Support
| | |-+  Proxy with Mikrotik gateway (deoesnt work as desired)
0 Members and 0 Guests are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Proxy with Mikrotik gateway (deoesnt work as desired)  (Read 68612 times)
Jr. Member
Offline Offline

Posts: 1

« on: Saturday 12 December 2009, 04:42:25 am »

Hello everyone !!
I just registered cause there is something weird going on with my endian setup.
My network goes like this:

                                                                  WiFi "hotspot"                       ENDIAN FW (IP:
                                                                           ^                                         ^
                                                                            |                                          |
                                                                            |                                          |
                             (PPPOE)                    (ROUTEROS 3.22)

I think all important network details are there, my Endian FW has a GREEN ONLY ethernet setup, and RED is configured as Gateway on wich is the Mikrotik Routerboard.
My need right now is to add WEB CACHE to my existing network, for anything else i will use another PC, this is a squid only box.

For some strange reason, if i redirect from bouterboard something like port 80 traffic to (proxy) the computer cant browse internet anymore, not even google.
Browser displays TIMEOUT error after some seconds (firefox) and internet explorer waits like a minute and says it can show the website.

BUT if i configure browsers manually to proxy everything works PERFECTLY, im clueless !!
Reading some endian doentation i learnt about the .PAC proxy auto configuration file, i didnt know that, so i tried and it works too, even with cached content.

I guess i dont need a transparent proxy, basically because the routerboard acting as gateway can redirect traffic to proxy port. Also i made a rule in the routerboard to accept connections from proxy, just in case.

I dont know what else to try, im fighting with this about 3 days now and i really dont want to give up. It seems the routerboard acting as a gateway CAN comunicate with proxy, but for some reason proxy allows clients to use it and not the routerboard !!!

Did some other tests:

Surprisingly i CAN access https://wiki.ubuntu.com/, wich happened to be in a list of bookmarks i had, and i can browse the entire site and links as long as they dont point to another website.

Also i CAN browse cached content (pictures at least, jpg format) or so it seems, i disabled forwarding rule on routerboard, cached some High Resolution pictures, activate rule again, and via bookmark i can access them.

And this is what "connections" page shows when i try to open a folder with some bookmarks, wich obviously i cant access.    52597    8080    tcp    SYN_RECV    0:00:59    52596    8080    tcp    SYN_RECV    0:00:57    52590    8080    tcp    SYN_RECV    0:00:55    52591    8080    tcp    SYN_RECV    0:00:54    52582    8080    tcp    SYN_RECV    0:00:34    52584    8080    tcp    SYN_RECV    0:00:34    52585    8080    tcp    SYN_RECV    0:00:34    52583    8080    tcp    SYN_RECV    0:00:33    32789    123 (NTP)    udp         0:00:16    61902    8080    tcp    SYN_RECV    0:00:14    62331    8080    tcp    SYN_RECV    0:00:14    61903    8080    tcp    SYN_RECV    0:00:13    55726    8080    tcp    SYN_RECV    0:00:13    61901    8080    tcp    SYN_RECV    0:00:13    64301    8080    tcp    SYN_RECV    0:00:13

And this is mt access policy rule (i tried disabling firewalls also, same results)

#     Policy             Source     Destination      Authgroup/-user      When     Useragent
1    unfiltered access  ANY                 ANY           not required    Always    ANY

Any help will be appreciated !!!
Im doing the best i can to give you details but if anyone needs any other details ill be glad to post them, just please help me solve this lol.
Thanks for reading =)
Pages: [1] Go Up Print 
« previous next »
Jump to:  

Page created in 0.031 seconds with 18 queries.
Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Design by 7dana.com