Welcome, Guest. Please login or register.
Did you miss your activation email?
Friday 12 August 2022, 03:59:51 am

Login with username, password and session length

Visit the official Endian Community Mailinglist  HERE
14173 Posts in 4334 Topics by 6325 Members
Latest Member: edegiobbi
Search:     Advanced search
+  EFW Support
|-+  Support
| |-+  EFW SMTP, HTTP, SIP, FTP Proxy Support
| | |-+  SMTP Proxy Broken
0 Members and 0 Guests are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: SMTP Proxy Broken  (Read 7802 times)
TheEricHarris
Full Member
***
Offline Offline

Posts: 86


« on: Wednesday 03 September 2008, 01:18:35 am »

Get this in the SMTP logs:
amavis[3564]: (03564-01) (!)Clam Antivirus-clamd: Can't connect to INET socket 127.0.0.1:3310: Connection refused, retrying (2)
Sep 2 08:32:46 amavis[3564]: (03564-01) (!)run_av (Clam Antivirus-clamd, built-in i/f): Too many retries to talk to 127.0.0.1:3310 (Can't connect to INET socket 127.0.0.1:3310: Connection refused) at (eval 40) line 293.
Sep 2 08:32:46 amavis[3564]: (03564-01) (!!)Clam Antivirus-clamd av-scanner FAILED: CODE(0x86e4e00) Too many retries to talk to 127.0.0.1:3310 (Can't connect to INET socket 127.0.0.1:3310: Connection refused) at (eval 40) line 293. at (eval 40) line 491.
Sep 2 08:32:46 amavis[3564]: (03564-01) (!!)WARN: all primary virus scanners failed, considering backups

After a reboot, incoming emails will just sit in the queue.  If I shutdown amavis and restart it (from /etc/init.d), mail starts flowing. 

What the heck is going on?
Logged
..::Bit71::..
Full Member
***
Offline Offline

Posts: 11


« Reply #1 on: Thursday 04 September 2008, 12:50:22 am »

Same problem........
i must to deactive the antivirus on the smtp proxy....
the same problem happened when active the antivirus in pop3......

Not resolve...........


Bye
Logged
TheEricHarris
Full Member
***
Offline Offline

Posts: 86


« Reply #2 on: Saturday 06 September 2008, 06:41:40 am »

Definitely a bug...

Whenever you make changes to the SMTP proxy, it restarts everything.  The issue is amavisd doesn't restart.  If it's off, emails will just sit in the queue.  You must do /etc/init.d/amavisd start and all is well.

Please fix this for next release!
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  

Page created in 0.052 seconds with 18 queries.
Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Design by 7dana.com