Welcome, Guest. Please login or register.
Did you miss your activation email?
Saturday 03 December 2022, 02:48:16 am

Login with username, password and session length

CLICK HERE for the The official Endian Roadmap and Issue tracker
14186 Posts in 4342 Topics by 6352 Members
Latest Member: jlstuhlfauth
Search:     Advanced search
+  EFW Support
|-+  Support
| |-+  EFW SMTP, HTTP, SIP, FTP Proxy Support
| | |-+  HTTP Proxy will not activate
0 Members and 0 Guests are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: HTTP Proxy will not activate  (Read 17068 times)
bnhansen
Jr. Member
*
Offline Offline

Posts: 3


« on: Wednesday 07 May 2014, 02:32:26 pm »

I have done a fresh install of Endian 3.0 and at first ClamAv would not update however, I have now managed to get that to load and update.  The antivirus engine indicates its active.  I still cannot get the HTTP Proxy to load nor is there any log on the HTTP Proxy.  As soon as I go to the HTTP Proxy page I get a proxy updating popup that never goes away.  On an EFW-update I get a message that there are no new interesting updates.  Rebooting does not change the condition - HTTP proxy will not activate.  I tried removing the HTTPS service then stopping (but it was never started) and starting the HTTP Proxy however that made no difference.

Has anyone run into this condition with 3.0 and found a workaround?
Logged
bnhansen
Jr. Member
*
Offline Offline

Posts: 3


« Reply #1 on: Wednesday 07 May 2014, 09:47:13 pm »

I have also restarted through SSH httpd with no helpful result in starting the Web proxy.  In the log I have the following error:

2014-05-07 07:40:53   httpd: [Wed May 7 07:40:52 2014] [error] mod_ssl Cannot open SSLSessionCache DBM file `/var/log/httpd/ssl_scache" for writing (store) (System error follows)
System   2014-05-07 07:40:53   httpd: [Wed May 7 07:40:52 2014] [error] System: No such file or directory (errno 2)
System   2014-05-07 07:40:53   httpd: [Wed May 7 07:40:53 2014] [error] [client 192.168.1.39] File does not exist /home/httpd/html/images/close.gif
System   2014-05-07 07:40:55   httpd: [Wed May 7 07:40:54 2014] [error] [client 192.168.1.39] File does not exist /home/httpd/html/images/close.gif

My Green, Orange & Blue zones are set to use HTTP Proxy transparently so it should be called to activate however, everytime I go to the HTTP Proxy tab I get an orange screen in the tab saying "Proxy settings have been applied successfully" without even changing any settings.  Turning the service off with the radio button then on simply causes the wait I'm updating message to come on and never go off.

Anyone run into this before?  I'm wondering if I should go back to the previous version and then upgrade it to 3.0 if that would fix this condition.
Logged
Chrendian
Jr. Member
*
Offline Offline

Posts: 2


« Reply #2 on: Wednesday 14 May 2014, 07:36:24 pm »

After applying some changes via endian website frontend , My http proxy server was hanging too.
It just displayed "Proxy settings are being applied"
I could get rid of it, by surfing back to the start url.
This caused a Major security problem, as internet access was suddenly opened to all sites!
If i check the system dashboard status, http proxy server is turned off!
Another issue was that no mails were sent out, in the mail queue lots of messages that ClamAV failed

I solved this by loggin in with ssh, and manually restarting some processes:
# /etc/init.d/clamd start
# /etc/init.d/squid start
# /etc/init.d/spamassasin start

I fear these fixes are temporarily.
Logged
Chrendian
Jr. Member
*
Offline Offline

Posts: 2


« Reply #3 on: Wednesday 14 May 2014, 07:59:56 pm »

Update
I enden updating clamAV in ssh:
# freshclam

and i did a reboot.

the system seems to work now
touchwood...
Logged
Dr. Cecil
Jr. Member
*
Offline Offline

Posts: 2


« Reply #4 on: Friday 23 May 2014, 02:55:25 pm »

I tried using "freshclam" and it gave me the following error:

Error: Can't create temporary directory /var/signatures/clamav/clamac-e626c.....
Hint: The database directory must be writable for UID 1001 or GID 108

So, because I am not very experienced with Linux... I found the following command through Google:

sudo chmod -R a+rwx /var/signatures/clamav

Please don't yell at me if I broke some sort of cardinal sin here.

I then used "freshclam" and it told me my installation was outdated, then proceeded to automatically download the update, ending in:

connect(): Connection refused
ERROR: NotifyClamd: Can't connect to clamd on 127.0.0.1:3310

Probably something to do with the firewall not allowing that port number out.

I have done a reboot, and now... it gets stuck on "CLAMAVCRON-I-Start         92%"

Swing and a miss.
Logged
Dr. Cecil
Jr. Member
*
Offline Offline

Posts: 2


« Reply #5 on: Friday 23 May 2014, 03:18:50 pm »

Alright... must turn off proxy and HTTPS proxy before rebooting, then turn it back on later.

All working now, except for filtering HTTPS traffic. I have a certificate there, but it just lets the traffic through...
Logged
gsv
Full Member
***
Offline Offline

Posts: 16


« Reply #6 on: Thursday 05 June 2014, 08:14:48 pm »

Dr.Cecil is right......i have done this to and its working now
Logged
tbl
Jr. Member
*
Offline Offline

Gender: Male
Posts: 5


« Reply #7 on: Friday 18 July 2014, 07:09:25 pm »

hi
I am having here the same problem.
# freshclam from ssh just returns clamaV is outdate witch is not a problem I guess (signatures are okay)

turning off proxy, rebooting and turning on back doesnt fix the problem.

Status window returns "web proxy" is off Sad

any idea ?
Larry
Logged

LarryT
tbl
Jr. Member
*
Offline Offline

Gender: Male
Posts: 5


« Reply #8 on: Friday 18 July 2014, 08:33:23 pm »

okay,
done
my execption list contained bad entries refused by squid on efw 3

works like a charm Smiley
Logged

LarryT
Pages: [1] Go Up Print 
« previous next »
Jump to:  

Page created in 0.081 seconds with 19 queries.
Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Design by 7dana.com